CHAPTER 16

INTRODUCING OUR DEVELOPMENT
ENVIRONMENT: UNITY
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Topics

* Downloading Unity

= Why Choose Unity?

= Why Choose C#?

* Running Unity for the First Time

* The Unity Demo Project: AngryBots
= Unity Features Shown in AngryBots
= Setting Up the Unity Window Layout

* Understanding the Unity Window Panes
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Downloading Uni

B unity - Download and St=1 x

€« C # unity3d.com/unity/download | D

Language: English ~

Unity Gallery Asset Store Learn Community Company Buy Download Q

Workflow Quality Animation Performance Multiplatform  Collaboration  What's New

The free version of Unity for OS X. Includes
publishing support for iOS, Android, Windows
Store, Windows Phone, BlackBerry, desktop
and Web, and a 30 day trial of Unity Pro (with
Pro publishing for iOS, Android, Windows
Store, Windows Phone and BlackBerry).

Download Unity 4.3.4

em Requirements

Copyright © 2014 Unity Technologies a
Jobs Blog Contact Legal Privacy Poicy Cookies
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Downloading Unity

= Unity is always available for free from Unity's official
website: http:/unity3d.com/download

B unity - Download and St=1 x
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Unity Gallery Asset Store Learn Community Company Buy Download Q
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The free version of Unity for OS X. Includes
publishing support for iOS, Android, Windows
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Pro publishing for iOS, Android, Windows
Store, Windows Phone and BlackBerry).

Download Unity 4.3.4
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Downloading Unity

= Unity is always available for free from Unity's official
website: http:/unity3d.com/download

— Download it now!

B unity - Download and St=1 x

L C n unity3d.com/unity/download ! ) =

Language: English ~

Unity Gallery Asset Store Learn Community Company Buy Download Q

Workflow Quality Animation Performance Multiplatform  Collaboration  What's New

The free version of Unity for OS X. Includes
publishing support for iOS, Android, Windows
Store, Windows Phone, BlackBerry, desktop
and Web, and a 30 day trial of Unity Pro (with
Pro publishing for iOS, Android, Windows
Store, Windows Phone and BlackBerry).

Download Unity 4.3.4

]

D |

Copyright © 2014 Unity Technologes a
Jobs Blog Cortact Legal Prvacy Polcy Cookies <
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Why Choose Unity?

= Unity is Free

= Write once, deploy anywhere
— PC, Mac, Linux
— Web

— i0S, Android, and other mobile devices

— Various game consoles

= Great support
— Documentation

— Dev community

= Ease of use
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Why Choose C#

= Unity can use C#, UnityScript (JavaScript), or Boo
= No one uses Boo

= JavaScript is forgiving and simple
— But this means that it allows a lot of sloppy behavior
— And this sloppiness makes coding slower in the long run
= C# is a modern language with the capabilities of Java
and the syntax of C++
— Extremely flexible and robust
— Enforces good coding practices

— Leads to greater student confidence and proficiency
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Running Unity for the First Time

= |nstall Unity

— The installer should be located in your Downloads folder

* Licensing

— When you first launch Unity, you'll need to register and get a
license

— Choose the free version for now
— Unity Pro costs $75/month

— You can purchase a year-long student license for Unity Pro
from: http:/www.studica.com/Unity-store
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The Unity Demo Project: AngryBots

The Unity window when it opens for the first time
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The Unity Demo Project: AngryBots

= AngryBots Controls
— Movement is controlled by WASD or Arrow Keys
— The gun aims at your mouse pointer
— Press the left mouse button to fire

— Environmental awareness
« Standing next to a circular door will cause it to open

- Standing next to some computers will change the wires leading from
them from red to green and unlock doors

* Try playing for about 10-15 minutes
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Unity Features Shown in AngryBots

= Shaders

— A: Depth of field shader (Unity Pro only)
— B: Reflections (Unity Pro only)
— C: Animated texture (raindrops)

Y3 AngryBots.usity - 4-0_AngrySots - Web Player
) + B3 e ]
«
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Unity Features Shown in AngryBots

= Shaders

— A: Depth of field shader (Unity Pro only)
— B: Reflections (Unity Pro only)
— C: Animated texture (raindrops)

= Character rigging and animation

— Animation blending allows the character to move in one
direction while looking in another

= Artificial Intelligence-based Pathing

— Enemies will move around objects in a room to track down
the player
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window
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Setting Up the Unity Window Layout

= Unity allows lots of flexibility in the layout of its
window

* The following instructions will guide you to the
layout that is used throughout the book.
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Setting Up the Unity Window Layout

006 AngryBots.unity - 4-0_AngryBots - Web Player "
! O S &) o | ®Local > 1l M { Layers « [ Layou vl
W Sceme SR = Hierarchy = B fropct QR © inspector -112_![
- - 4 Split

Textured :  RGE s 20 <) e - Giamos * P Creane * P Create * 4N
Default
» Enemies ¥ Favorites Assets i
» Envirommentidynamic) AN Materals a Wide
» Envirommenti(semi-static) AN Models N
» Environmentisounds) AN Prefabs Save Layout
» Enviromment(static) AN Scripts Delete Layout....

: ::: o 'Q . AngrySots AngrySon
> Player W AngryBots
» MoodBoxes Wl Animations
Wl Edinor
» &l Explosions
il fonts
sl Cumos
wl Materialy
» &l Objects
W PhyysicMaterials
Wl Pugins
» il Prefabs
Wl Resources
» il Scenes
>l Scripes
* &l Shaders
» il Sounds
l Standard assets Glamss Matertals
>l Textures

Revert Factory Settings.

Animatansy tawr

Gxplovians Fonm

€ Game -
free Aspect . Maximize on May | St | Guomos

2

L

H

£
lEI

Pugies

i

Resources

B
‘BB

— _
First: Choose the 2 by 3 window layout




Setting Up the Unity Window Layout

23 Project © Inspector

] Create "| (Q
¥ 7 Favorites Assets » One Column Layout
: v Two Columns Layout k
@AII Materials
@AII Models VEM
@AII Prefabs Close Tab
@AII Scripts
Add Tab [>

AngryBots
Animations ——
Editor
» 3 Explosions
Fonts
Cizmos AngryBats
Materials -
» & Obijects i—

Set the Project pane to One Column Layout
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the Arrow cursor
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Setting Up the Unity Window Layout

= Unity window panes can be moved in two ways:

— Panes can be grabbed by their tab and moved as shown by
the Arrow cursor

— Pane borders can also be moved as shown by the Left-Right
Resize Arrow cursor.
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Setting Up the Unity Window Layout

=) ) ) < AngryBots.unity - 4-0_AngryBots - Web Playe

@ Project

a0

= 5|20 & | 4 | Etects =] | Gizmos ~| @Al | Create - | B
| Create -| (& » Enemies
{ AngryBots » Environment(dynamic)

> AngryBots » Environment(semi-static)
» @ Animations » Environment(sounds)
» @l Editor » Environment(static)
» &l Explosions » Main Camera
>l Fonts » Misc
> Gizmos » MoodBoxes
>l Materials » Player
» & Objects
» Gl PhysicMaterials
» Gl Plugins
» Gl Prefabs ]
> Resources
Vi scenes Ghostedk

€0 3-4_girth Sna pped : . GhOSt

» &l 3-4_Birth V=Y
> & 3-4_pain Pane Pane;

& 3-4_Pain '

€ Default

€ Escape

» Gl Escape
i Scripts
> Al

» & Animation
>l Editor

> & Fx

> Managers
» G Misc

» @ Modules
» Gl Movement
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Setting Up the Unity Window Layout

= When a pane is moving, it is ghosted

=) ) ) < AngryBots.unity - 4-0_AngryBots - Web Playe

@ Project
5 - +| (avA Create *
| Create +| (@ | 3| | RCE $/| 20 ¢ | <) | Effects |~ | Gizmos | |

(G

» Enemies
{ AngryBots » Environment(dynamic)

> AngryBots » Environment(semi-static)
» @ Animations » Environment(sounds)
» @l Editor » Environment(static)
» &l Explosions » Main Camera
>l Fonts » Misc
> Gizmos » MoodBoxes
>l Materials » Player
» & Objects
» Gl PhysicMaterials
» Gl Plugins
» Gl Prefabs ]
> Resources
Vi scenes Ghostedk

€ 3-4_8irth Sna pped : oy GhOSt

» &l 3-4_Birth 1 V=Y
> & 3-4_pain Pane Pane;

& 3-4_Pain '

€ Default >

€ Escape

» Gl Escape
i Scripts
> Al

» & Animation
>l Editor

> & Fx

> Managers
» G Misc

» @ Modules
» Gl Movement
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Setting Up the Unity Window Layout

= When a pane is moving, it is ghosted

* When in a location that it can snap to, it will unghost
and move into the snhapped posmon

< AngryBots.unity - 4-0_AngryBots - Web Playe

» Enemies
» Environment(dynamic)

"8 > Environment(semi-static)
» Environment(sounds)

» Environment(static)

» Main Camera

» Misc

» MoodBoxes

» Player

M GhostedE
e
Rane
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Setting Up the Unity Window Layout

G ron e - O impe e A

o T o

L
> Argr ety (res sameres yeame
- Areatce Ures smmers yom
- Lo P Lrew snmevd Lonnd
> 1 o oy e (res samever s
> foons Mam Camers
» b Gurmea w
> Materiahy » MoccBa e
"

Gra e

vvvvvv

>k W rrert

‘Zeie. Project Pane Hierarchy Pane

Inspector Pane

Move the panes to the locations shown above



Setting Up the Unity Window Layout

= + £ > 0

B e archy S Scene .| © mpe s aa

” - bvouriar

5 Ovtau

''''''

I:Em Project Pane Hierarchy Pane Inspector Pane

o
* i Sandar t nven
> Teatere

Console Pane

R ——- —

You also need to add the Console pane
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BT

i

Project Pane Hierarchy Pane Inspector Pane

Console Pane
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Setting Up the Unity Window Layout

= Adding the Console pane:

aikk

e NPT TITTR
%liiriir§§§f§€§?f§g§§l HHTH g

i

Project Pane Hierarchy Pane

Inspector Pane

Tt

Console Pane
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Setting Up the Unity Window Layout

= Adding the Console pane:

— From the menu bar, choose Window > Console

“f€§?i§§§§; ii iii; i i{_f +8

i

i
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Setting Up the Unity Window Layout

= Adding the Console pane:
— From the menu bar, choose Window > Console

— Drag the Console pane below the Hierarchy pane

1Bk

AR

it

3

.

i

Project Pane Hierarc! hy Pane

fif
i
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Setting Up the Unity Window Layout

= Adding the Console pane:
— From the menu bar, choose Window > Console

— Drag the Console pane below the Hierarchy pane

— Move the Project pane to the left of the Hierarchy pane

ots uasy - &0 Aogryots - Web Player

s

ﬁﬁix

i

Project Pane Hierarc hy Pane Inspector Pane

fif
i

Console Pane
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Setting Up the Unity Window Layout

¥ Inspector

Delete Layout...
Revert Factory Settings...
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Setting Up the Unity Window Layout

= Save this layout!

2by3
4 Split
Default
Tall
Wide

¥ Inspector

Save Layout...
Delete Layout... k}
Revert Factory Settings...
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Setting Up the Unity Window Layout

= Save this layout!

— Choose Save Layout... from the Layout pop-up menu

¥ Inspector

Default
Tall
Wide

Save Layout...
Delete Layout... y
Revert Factory Settings...
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Setting Up the Unity Window Layout

= Save this layout!
— Choose Save Layout... from the Layout pop-up menu

— Name the layout: (don't include quotation marks in the name)
- " Game Dev" on Mac with a space before the "G"
- "_Game Dev" on PC with an underscore before the "G"

2by3
4 Split
Default
Tall
Wide

¥ Inspector

Save Layout...
Delete Layout... k
Revert Factory Settings...
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Setting Up the Unity Window Layout

= Save this layout!
— Choose Save Layout... from the Layout pop-up menu

— Name the layout: (don't include quotation marks in the name)
- " Game Dev" on Mac with a space before the "G"
- "_Game Dev" on PC with an underscore before the "G"

— These names will sort the new layout to the top of the list

Layers - Layout =
2by3

4 Split

Default

Tall

Wide

Save Layout...

Delete Layout... k
Revert Factory Settings...

¥ Inspector
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Understanding the Unity Window Panes

" Pvet | @ Codal

* Urew samensi s1aex)
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X
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]

S Project Pane Hierarchy Pane Inspector Pane

Console Pane

Scene Pane: Allows you to move around the 3D scene
and select, move, rotate, and scale GameObjects.



Understanding the Unity Window Panes
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.I:‘.:r.« Project Pane Hierarchy Pane Inspector Pane

Console Pane

Game Pane: Shows you a preview of the gameplay.
Shows the view from the Main Camera in the scene.
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Console Pane

Hierarchy Pane: A list of every GameObiject in the scene.
Maintains a hierarchy of parent and child GameObjects.
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Inspector Pane

Console Pane

Project Pane: Collection of all assets in the Unity project:
everything from models to C# code, images, and sounds.
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Console Pane

Inspector Pane: Shows details of any selected asset.
Allows you to edit the details of any GameObject.



Understanding the Unity Window Panes
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Console Pane

Console Pane: Shows messages from Unity and from the
C# scripts that you write. Used extensively in Chapter 18.
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Chapter 16 — Summary

= Unity and C# are the best combination for learning
independent game development

= Unity has several different licenses, but for now, you
only really need to use Unity Free

* The Unity window can accept any number of layouts

— You created the " Game Dev" layout that is used throughout
this book.

* The next chapter will discuss C# in greater detail
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