
A p p e n d i x  C

ONLINE REFERENCE

Whereas many online references just give you 

a list of websites to check out, I thought using 

this appendix to show you where and how I 

tend to look for answers online when I need 

them would be more useful. Appropriately, this 

includes a few basic links, but it also includes 

strategies for tracking down information and 

answers to problems that you might encounter.

I recommend reading this straight through 

once (it's very short) and then returning to it 

when you encounter an issue.
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2 Appendix C Online RefeRence

Tutorials
Unity has created a series of tutorials over the years that can be very useful to check out. 
This book focuses on game prototyping tutorials to help you understand how to pro-
gram game mechanics, whereas the tutorials created by Unity tend to spend an equal 
amount of time on art assets, animation, building scenes, and visual effects in addition 
to scripting. This book is about you learning how to design and prototype games; their 
tutorials are about learning all the different features of the Unity engine.

Be aware when looking at these that many were made with older versions of Unity, 
and they sometimes don't update the tutorials to match the new version of the engine 
(meaning that sometimes the elements of the Unity interface that the tutorial describes 
or some code libraries that they use might have changed).

Unity's website offers a Learn section that is meant to introduce you to Unity through 
several different tutorials. This link takes you to that page. Choose a topic that you want 
to learn about, and you can view a video tutorial to help you do so:

■ Learn section—Tutorials: https://unity.com/learn

Unite Conference
Unity runs its own Unite conference all over the world, sometimes hosting it multiple 
times per year. Unity holds versions of Unite all over the world every year and records 
many of the talks. Unfortunately, the archive of old Unite videos is no longer on Unity's 
website; however, you can learn about and register for the next Unite conference at 

■ http://unite.unity.com/

Unity's YouTube Channel
Luckily, there is an archive of Unite videos and many more hosted on YouTube. They also 
have a truly impressive collection of video playlists (with 170 different playlists as I write 
this).

■ Unity's YouTube channel: https://youtube.com/c/unity

■ Unity's collection of video playlists: https://youtube.com/c/unity/playlists

■ To search the Unity channel for Unite videos: https://youtube.com/c/unity/
search?query=Unite

If you subscribe to Unity's channel, you'll find out about new and upcoming features as 
they're announced. Of course, there are also dozens of other content creators making 
tutorials about Unity on YouTube. They vary in quality, of course, but some are quite 
good.
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Programming
As you delve further into programming Unity, you'll find that the documentation for 
programming Unity with C# is primarily located in two places: Unity's scripting docu-
mentation and the Microsoft C# reference. The Unity scripting documentation does a 
fantastic job of documenting Unity-specific features, classes, and components, but it 
doesn't cover any of the core C# classes (such as List<>, Dictionary<>, and so on). 
For these, turn to Microsoft's C# documentation. I recommend first looking for some-
thing in the Unity documentation available on your computer, and if it's not there, then 
look in the Microsoft docs.

Unity Scripting Reference
Unity scripting references include the following:

■ Online: https://docs.unity3d.com/2020.3/Documentation/ScriptReference/1

■ Local: From within Unity, choose Help > Scripting Reference from the menu bar. This 
opens a version of the reference that is stored locally on your computer. Even if you 
don't have an Internet connection, this reference is available. (I use it frequently 
while traveling.)

■ From within Visual Studio: You can also access the Scripting Reference by click-
ing a term you want to look up in Visual Studio and then choosing Help > Unity 
API Reference from the Visual Studio menu. Alternatively, you can use the following 
keyboard shortcut:

■ macOS: Press Command-' on the keyboard (' is the single quote that is next to 
the return key on U.S. keyboards).

■ Windows: Press Ctrl+Alt+M and then press Ctrl+H (I don't know what Visual 
Studio for Windows has against simple keyboard shortcuts, but whatever it is, 
they feel very strongly about it).

Microsoft C# Reference
Search Bing.com for Microsoft C# Reference. The first hit should be what you're looking 
for. As of the time of writing this book, the direct URL is

■ https://docs.microsoft.com/en-us/dotnet/csharp/language-reference/

Stack Overflow
Stack Overflow is an online community of developers helping developers. People post 
questions, and other members of the site answer them. In a bit of gamification, those 

1. This is the specific link for Unity version 2020.3 LTS. The more general link that will update 
with the latest Unity LTS version over time is https://docs.unity3d.com/ScriptReference/.
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who give the best answers (as voted by other members) earn experience points and 
prestige on the site:

■ http://stackoverflow.com

Often, when I'm trying to figure out how to do something new or unusual, I'll end up 
finding a good answer on Stack Overflow. For instance, if I want to know how to sort a 
List<> using LINQ, I enter "C# LINQ sort list of objects" into Google, and as I write this, 
the top eight hits are Stack Overflow questions. I usually find myself there via a Google 
search rather than starting on stackoverflow.com, but when a search result is on stack-
overflow.com, it's my first choice for finding good answers.

Learning More C#
I highly recommend two additional books for learning more about C#:

■ For beginners: Rob Miles's C# Programming Yellow Book, http://csharpcourse.com

Rob Miles was a lecturer at the University of Hull, is a Microsoft MVP, and has written 
a fantastic book on C# programming that he updates often. You can find the current 
version on his website. It is witty, clear, and comprehensive.

■ For reference: C# 8.0 Pocket Reference, https://oreilly.com/library/view/c-80-pocket/
9781492051206/

Although there is now a C# 9.0 version of this reference, Unity 2020.3 LTS uses the 
C# 8.0 standard, so this is the reference for you. Any time I have a C# question, this 
is the first place I turn. It is a truncated version of the information in O'Reilly's C# in a 
Nutshell book, but I actually find the pocket reference more useful. It also includes a 
ton of information on LINQ, XML documentation, and dozens of other topics (in just 
under 250 pages).

Alternatives to Visual Studio
Although the version of Visual Studio that is installed with Unity is quite good, it does 
sometimes have issues, so I have found a couple alternatives that work very well with 
Unity:

■ Visual Studio Code: https://code.visualstudio.com/docs/other/unity 

There's an old joke by David L. Norris that describes operating systems as if they 
were airlines.2 You should follow the footnote to read the whole thing, but the 
punchline of the joke is:

Linux Airlines: Disgruntled employees of all the other OS airlines decide to start 
their own airline. They build the planes, ticket counters, and pave the runways 

2. http://www.webaugur.com/bazaar/53-what-if-operating-systems-were-airlines.html—accessed 
September 26, 2021.
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themselves. They charge a small fee to cover the cost of printing the ticket, but you 
can also download and print the ticket yourself. When you board the plane, you 
are given a seat, four bolts, a wrench and a copy of the seat-HOWTO.html. Once 
you are settled, the fully adjustable seat is very comfortable, the plane leaves and 
arrives on time without a single problem, and the in-flight meal is wonderful. You 
try to tell customers of the other airlines about the great trip, but all they can say is, 
"You had to do what with the seat?"

I think of this joke every time I use Visual Studio Code. Code is open source, extreme-
ly fast and lightweight, and it works well with Unity, but to get it working, you need 
to install a few plug-ins (through its built-in plug-in browser). It does break every 
once in a while, but when that happens, I just uninstall and reinstall the plug-ins.

■ Rider: https://www.jetbrains.com/rider/ 

Rider is a very powerful IDE that works well with Unity. I used it throughout the 
development of this book (because code copied from Visual Studio does not include 
the color information). It is normally priced at $13.90 per month, but Jetbrains makes 
it available for free to university students and educators.

Searching Tips
Any time you want to search for something having to do with C#, make C# the first term 
in your search. If you just search for "list", the first thing to come up has nothing to do 
with coding. Searching for "C# list" gets you to the right place immediately.

Similarly, if you want to find anything related to Unity, be sure to make Unity your first 
search term.

Also, remember that Google is not the only search engine out there. In addition to Bing 
and Google, based on your individual concerns, you might consider trying:

■ Ecosia (http://ecosia.org): A search engine that at the time I wrote this had used the 
money generated from searches to plant over 145 million trees

■ DuckDuckGo (http://duckduckgo.com): A search engine famous for not tracking 
you or selling your personal information

Finding and Creating Assets
The following sections provide advice on finding various art and audio assets as well as 
code and tools to make your game development easier.

The Unity Asset Store
You can access the Asset Store by going to the website in a standard browser. The Asset 
Store has a huge collection of models, animations, sounds, code, and even complete 
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6 Appendix C Online RefeRence

Unity projects that you can download. Most of the assets are available for a small fee, 
and some of the assets on the site are free. Some assets are very pricey, but they are 
often worth it and can save you hundreds of hours of development:

■ https://assetstore.unity.com/

In the past, you would download assets from the Asset Store as a zip file and then 
manually decompress the file and add the assets to your project. Now, that has been 
replaced by the Package Manager. To install your Unity Asset Store assets via the Pack-
age Manager, choose Window > Package Manager from the main Unity toolbar and then 
choose Packages > My Assets, as shown in Figure C.1.

Figure C.1 Choosing Packages > My Assets to install Asset Store assets in the Unity Package 
Manager

Other Places to Find Models and Animations
These sites are some places to look for 3D models. Some are free, but many are paid. 
Also, be aware that many of the free ones are for noncommercial use only:

■ TurboSquid: http://www.turbosquid.com/

■ Google 3D Warehouse: http://3dwarehouse.sketchup.com/ 

Be aware that nearly all the assets on the Google 3D Warehouse site are in the 
SketchUp or Collada formats. Unity has an importer for SketchUp files, but as I am 
writing this, the importer only works with SketchUp 2015 files. You might need to 
open the SketchUp or Collada file in SketchUp and then save it as a SketchUp 2015 
file for Unity to import it correctly.

Tools to Create Your Own 3D Art Assets
Many times, stores and warehouses won't have the exact 3D art asset you need, or you'll 
just want to quickly mock up something as a placeholder. These tools can help you do that.
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■ Unity ProBuilder – 3D modeling in the Unity Editor: https://unity.com/
features/probuilder 

While not a place to download existing models, I have found ProBuilder to be an ex-
cellent tool to quickly mock up environments and models in Unity, and the students 
in my Game Level Design class use it to build their 3D levels.

■ Blender – An excellent free competitor to Maya, 3ds Max, and ZBrush:
http://blender.org 

Blender is a free, open source tool for modeling and animation. With the latest 
releases (version 2.8 and newer), Blender has seen a massive increase in adoption 
across the game and cinema industries to the point that at Michigan State University, 
we now teach Blender as our primary 3D modeling tool.

■ Houdini – Procedural 3D modeling: https://www.sidefx.com/products/houdini/ 

Houdini is professional software that approaches 3D modeling in a procedural way. 
Rather than model every aspect of every house in a neighborhood, Houdini allows 
you to tell it how houses are built, and then it will generate thousands of houses 
from which you can choose.

■ Asset generation tools in the Unity Asset Store: https://assetstore.unity.com/

Several great tools are available in the Asset Store that can help you quickly generate 
various types of models. These include Archimatix, Voxel Generator, Broccoli Tree 
Creator, and Terrain Composer, and many others.

Places to Find and Create Game Audio
Whether you're looking to record and edit your own audio or just looking for a quick 
way to make a placeholder explosion sound, one of these links can help you:

■ Audacity – Free audio editor and recorder: https://audacityteam.org 

Audacity is free, open source, cross-platform audio software that has many of the 
features of expensive audio editing software.

■ Reaper – Affordable, professional digital audio workstation: https://reaper.fm 

If you need a more professional solution than Audacity, Reaper is the way to go. 
Reaper is professional-level audio software, and as I write this, the "discounted"
license that is available to many only costs $60.

■ Freesound.org – Massive library of free sounds: https://freesound.org 

Freesound is an archive of more than 500,000 sounds that are all licensed under 
Creative Commons.

■ ChipTone – Online sound effect generator: https://sfbgames.itch.io/chiptone 

ChipTone is a browser-based tool that allows you to create 8-bit-style sound effects. 
It has several randomizers for different kinds of sounds (coin, zap, boom, jump, 1up, 
lose, hurt, and blip), and the UI is reminiscent of a MOOG synthesizer.

■ JFXR – Online sound effect generator: https://jfxr.frozenfractal.com 

JFXR is another browser-based tool that allows you to create 8-bit-style sound effects. 
It has randomizers for pickups, shots, explosions, damage, jumping, and so on and 
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allows you to save and tweak any generated sounds. The standout feature is that it 
saves a history of every sound it has generated for you, so you don't lose the perfect 
sound by accidentally clicking the randomizer button one too many times.

2D and User Interface Assets
These links will take you to several libraries of 2D art assets you can use. Or, if you wish 
to create your own, Photopea is an ad-supported online clone of Photoshop that is 
shockingly powerful.

■ itch.io Game Assets – Free and paid assets: https://itch.io/game-assets 

itch.io now has more than 24,000 projects in its Game Assets section, most of which 
are 2D. 

■ Kenny.nl – Free 2D game assets and tilemaps: https://kenney.nl/assets 

A collection of many 2D assets with a public domain license (also available on itch.io).

■ Unity Asset Store: https://assetstore.unity.com/2d and /2d/gui 

The Unity Asset Store also has many free and paid 2D and GUI asset packages.

■ Piskel – Free online sprite and animation editor: https://www.piskelapp.com/

■ Photopea – Free online Photoshop competitor: http://photopea.com 

Fonts
Nearly all the fonts on these sites are free for noncommercial use, but you will often 
need to pay to use them on commercial projects:

■ http://www.1001fonts.com/

■ http://www.1001freefonts.com/

■ http://www.dafont.com/

■ http://www.fontsquirrel.com/

■ http://www.fontspace.com/

Other Tools and Educational Discounts
If you are a student or faculty member of a university, you qualify for many discounts on 
software.

■ Adobe Creative Cloud: http://www.adobe.com/creativecloud/buy/students.html  

Adobe offers the entire Creative Cloud suite of its tools to students at a discounted 
monthly rate, good for one year. This includes Photoshop, Illustrator, Premier, and 
others. If you cancel your subscription after a year, you can start it again and get the 
student rate for another year.
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■ Affinity – Adobe Creative Cloud Competitors: http://affinity.serif.com

Serif makes Affinity Photo (a Photoshop competitor), Affinity Designer (an Illustrator 
competitor), and Affinity Publisher (an InDesign competitor), which seem to be very 
good programs and only cost about $40 each to own forever (as opposed to paying 
Adobe every month). No student discount, but relatively cheap and high quality.

■ AutoDesk – 3D art tools: https://www.autodesk.com/education/edu-software/

AutoDesk gives students and educators a free, renewable license for almost any of 
their tools, including 3ds Max, Maya, Motionbuilder, Mudbox, and more.

■ Blender – Free 3D art tool: http://www.blender.org

Blender is a free, open source tool for modeling and animation. It includes many 
of the capabilities of software like Maya, 3ds Max, and Zbrush but is entirely free 
and can be used for commercial purposes. With the latest releases (version 2.8 and 
newer), Blender has seen massive increase in adoption across the game and cinema 
industries to the point that at Michigan State University, we now teach Blender as 
our primary 3D modeling tool.

■ Photopea – Free online Photoshop competitor: https://photopea.com

Photopea (which is pronounced "photo-pee") is an incredibly useful Photoshop 
clone that lives entirely online and is entirely free (supported by unobtrusive ads). 
This is the tool I recommend to my students whenever they need to quickly edit im-
ages. It lacks some of the most recent Photoshop tools (like Content-Aware Fill and 
such), but for basic—or even pretty advanced—image editing, it's free and can be 
accessed easily on the web.

■ Unity Student Plan: https://unity.com/products/unity-student

The student version of Unity's license changes somewhat frequently, but as of 2021, 
the Student Plan is available to students age 16 and older, and it includes a one-year, 
renewable license for Unity Pro, five seats of Unity Teams Advanced, Unity Cloud 
Build, and a special Student Asset Pack. You can do everything you need to do in this 
book with the free Personal license, but if you're working with more than two other 
people, the five seats of Unity Teams Advanced can be a big help. Similarly, if you're 
building to more than one platform, Unity Cloud Build is extremely helpful.
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